Brand

Security Software Update

Update Your Browser to Avoid Disruption to APL Websites

Why am I seeing this notice?


The web browser you're using is not the most current version and will not allow you to access APL's websites after security upgrades on September 25, 2017.

APL is upgrading to TLS 1.2 on September 25, 2017 in order to align with industry best practices for security and data integrity. Your action is required prior to September 15 to prevent any disruption in accessing APL websites, which include: ampublic.com, Quote Proposal Generator (QPG) and Online Service Center (OSC). This page contains information on APL's security software update and what you need to ensure uninterrupted access to APL websites.

What is TLS?


TLS stands for "Transport Layer Security." This protocol provides privacy and data integrity between two communicating applications. It's the most widely deployed security protocol used today, and is used for web browsers and other applications that require data to be securely exchanged over a network.

What is changing?


APL is upgrading to TLS 1.2 on September 25, 2017. On that date, we will begin disabling the TLS 1.0 encryption protocol, which will prevent you from accessing APL websites using your current browser.

Why is this happening?


At APL, "trust" is our #1 value and we are focused on continually updating our systems by using the latest security protocols. On September 25, 2017, APL will upgrade to TLS 1.2 encryption protocol in an effort to maintain the highest security standards and promote the safety of customer data.

How do I know if my browser needs to be updated?


If you are seeing this message, your browser will not be compatible with our new security software after September 25, 2017.

What can I do?


To avoid any further disruption, we encourage you to update your browser as soon as possible. Simply go to updatemybroswer.org to upgrade to the most current version of your web browser.

Continue to ampublic.com